Loading...

Power service preventing Windows from reaching login screen

Windows 8.1

Asked
Asked by: ikkisato

Here is my current setup:

Windows 10 Pro 64-bit 1607 running on EFI, boot camp partitioned Early 2013 retina Macbook Pro 13"

After a week of problem solving I have discovered this:

I am only able to install Windows 10 on the computer as long as the Thunderbolt to Ethernet adapter is attached. However, the adapter does not need to be connected to a network cable. When the adapter is not plugged into the thunderbolt port the install always hangs when it reaches the "Getting ready" screen. The loading icon will spin but the install does not continue even after waiting several hours. When the adapter is plugged-in everything runs smoothly and the "Getting ready" screen only takes several seconds. 

(I have tried almost every install method possible over the last 6 days including through boot camp, a manual partition, and on both EFI and legacy. I have also tried using both the boot camp generated install drive and also a standard Windows install drive--all downloaded and created with the most up-to-date versions. Unfortunately it is the same outcome every time.)

Once Windows 10 is installed I have found that I can only reach the login screen as long as the adapter is connected. When the adapter is not connected, Windows is only able to get to the "lock" screen, which requires a mouse click or keyboard action in order to proceed to the login screen. However, the OS remains unresponsive and does not react to keyboard inputs or mouse clicks.

(The mouse is able to move though. Repeatedly clicking and moving the mouse caused the cursor to lag and resulted in a subsequent BSoD with the stop code "Critical process died.")

Through a long process of problem solving I have determined that the windows service "Power" seems to be at fault. As long as the service is disabled, the OS is able to boot up regardless of whether or not the adapter is plugged-in. Currently I have the service disabled as a temporary fix, but I would like to resolve this issue for the future.

I was wondering what services the "power" service provides and if there is a way to patch it with a fix.

Further information can be found regarding my issue first posted at the Apple forum https://discussions.apple.com/message/31033945

I hope this is sufficient information, but I will get back ASAP if there is anything missing.

Thank you!

Answered
Download, install & activate 29/11/2016 0 Comment 14 views
Loading...

Comments ( 0 )

Notice!
No comments yet. Be first to comment!

Leave a reply