Loading...

Joystick no longer working in games; MAJOR mis-communication with drivers suspected.

Windows RT 8.1

Asked
Asked by: WilliamTaylor_963

This problem just started earlier today.  My Saitek X-45 HOTAS controller has worked for me quite well ever since I bought it during the XP days, but today games seem to no longer recognize it properly. Only the throttle is being correctly translated, the X- and Y-axis and rudder are not, even though the whole controller is calibrated in joy.cpl.

Like I said, this problem just started today, without warning. The controller acts the same way regardless of the USB port used. It IS calibrated in joy.cpl and works normally through there. I have tried uninstalling and reinstalling the drivers for it, but that didn't work. I'm suspecting a corrupted driver, possibly related to KB3201845, being to problem. The update in particular since that was the only "major" install between yesterday and today, and even that update required several attempts before completing successfully.

I'm going to try uninstalling KB3201845 and getting back to you with the results.

Answered
Windows Store 11/12/2016 0 Comment 10 views
Loading...

Comments ( 0 )

Notice!
No comments yet. Be first to comment!

Leave a reply